Main Site Blog Help

Android app not able to access lesson audio that had been previously downloaded


#1

I have been noticing a problem lately where the android app can’t access the lesson audio that was previously downloaded. I tried deleting the lesson and re-downloading but get the same error when I try to listen to the lesson.(see screenshot)

The weird thing is that the app doesn’t crash and the newest lesson works fine.


#2

I cleared the app cache and deleted the data for the app. Re-downloaded a lesson and it played once before the same issue happened again. @GwilymJames are you seeing other people report this issue for android?


#3

OK, I see the problem. If a lesson is downloaded, then the app is closed and you go back to listen to that lesson, you get the error popup. I will see if we can get it fixed. @Armel


#4

Hi @Matt_T, what OS are you using? I have the same error using Kitkat (4.4.4) although it’s not a problem with newer OS (M). Perhaps we can fix it if we know it’s happening on a particular software version.


#5

@GwilymJames I’m running Cyanogen OS 12.1 which is based on Lollipop 5.1.1. I’m also getting the error on my tablet which runs Kitkat 4.4.2.


#6

@GwilymJames @Armel Has there been a fix pushed through for this issue? I reverted to using the old android app for the last month or more, but did some testing on the new app over the last few days and haven’t noticed any issues so I wanted to check.


#7

Hi @Matt_T, I’ll send you a PM regarding our new Android app.


#8

I have the same problem with the Android app. Is there a secret to avoiding this problem?


#9

I am also having this problem. Any solution?


closed #10