Main Site Blog Help

Switching IME in Windows 10


#1

I just had a “Eureka” moment (or maybe that should be a “Well Duh” moment) regarding Chinese input in Windows 10 and I thought I would share it in case it helps anyone else.

The problem: You switch to Chinese input in one program, say to post a message on a ChinesePod forum in your web browser, then you switch back to the email you were typing or the novel you were writing, and your input language is stuck on Chinese. You type several key strokes before you brain catches up with what is happening and you have to backspace, change IME and type what you meant to. This never used to happen in previous versions of Windows so you assume it is just something that is broken and they will fix it eventually.

The solution:

Control Panel >> All Control Panel Items >> Language >> Advance Settings >> Let me set a different input language for each app window.